GNU MCU Eclipse

A family of Eclipse CDT extensions and tools for GNU ARM & RISC-V development

GNU ARM Eclipse OpenOCD v0.8.0-20150320* released GNU ARM Eclipse plug-ins v2.7.1-201503211846 released

GNU ARM Eclipse OpenOCD v0.9.0-20150320*-dev released

The latest development version of OpenOCD (0.9.0-dev) is now available as multiple platform specific binary packages.

Binary files »

For those who want the latest OpenOCD features before the stable version is announced, the latest OpenOCD version built from the development repository was released in packages explicitly marked as -dev.

The OpenOCD developers claim that the development versions should be generally safe to use. In case you encounter problems, please revert to the latest 0.8.0 stable release.

In order to allow for multiple versions to coexist at the same time, the OpenOCD packages are now installed in folders including the version and the timestamp (like 0.9.0-201503201830-dev).

For this mechanism to work, a new set of binaries for 0.8.0 was also released; there are no functional differences, only that the packages were changed to install in separate folders.

Please uninstall the previous versions and install these new versions.

The debug plug-in generally discovers the latest installed version, by using the Windows registry keys or by searching several designated folders. If you need to use a different version, update the ${openocd_path} variable accordingly.

[March 24, 2015; update]

The setup script was updated with code to prevent removing some registry keys when uninstalling an older version.