GNU MCU Eclipse

A family of Eclipse CDT extensions and tools for GNU ARM & RISC-V development

GNU ARM Eclipse plug-ins v2.12.1-201604190915 released GNU ARM Eclipse QEMU v2.6.0-20160728* released

GNU ARM Eclipse plug-ins v3.1.1-201606210758 released

Version 3.1.1-201606210758 is a new major release; the main change is adding support for Eclipse 4.6 Neon (CDT 9.x).

Binary files »

New features

  • none.

Addressed bugs

  • none.

Other changes

  • the minimum supported version is now CDT 8.6.0 from Luna SR2; Eclipse Kepler and previous are no longer supported;
  • the minimum Java version required is JavaSE-1.7.

Known problems

  • [#108] in certain conditions, the Enable flash breakpoints button does not function properly; will be fixed in the next release.